Mikrotik dengan Bot Telegram Interaktif

Mencoba membahas mengenai Bot Telegram Interaktif di router Mikrotik, dapat dikembangkan sendiri sesuai keinginan masing-masing. Akan lebih memudahkan kita untuk monitoring, setting, dan mungkin edit config pada Mikrotik

Mikrotik dengan Bot Telegram Interaktif

Apa yang harus dilakukan sebelumnya, ya… betul… mempunya botAPI, chatID, dan group ID

botAPI => didapat saat membuat bot, satu account telegram bisa membuat satu bot

Mikrotik dengan Bot Telegram Interaktif 1 | PAIDJO.COM

ChatID => ini dapat dilihat dengan cara, search pada telegram @get_id_bot

Mikrotik dengan Bot Telegram Interaktif 2 | PAIDJO.COM

GroupID => dapat dilihat dengan melihat update aktifitas telegram

https://api.telegram.org/bot<YourBOTToken>/getUpdates

note: agar lebih mudah, create group yang isinya nama bot yang sudah kita buat. Kemudian jalankan link URL diatas, akan muncul groupID

Membuat File Script pada Mikrotik

Untuk penamaan script harus sesuai dengan yang sudah diberikan

1. Script func_fetch

2. Script tg_config

botAPI => diisi dari API Token
defaultChatID => diisi ChatID
trusted => diisi GroupID

3. script get_cmd_help

untuk kode %0A\ => ganti baris (break line)

:local send [:parse [/system script get tg_sendMessage source]]

:put $params
:put $chatid
:put $from

:local text "Router ID:* $[/system identity get name] * %0A\
==================%0A\
MENU TERSEDIA%0A\
==================%0A\
/help%0A\
/mangle show <ip>%0A\
/ping to <ip>"
 
$send chat=$chatid text=$text mode="Markdown"
:return true

4. Script get_cmd_mangle

Script ini saya buat untuk melakukan check arah routingnya, atau menggunakan internet apa?
Semua ini bisa diubah sesuai keingin, silahkan berkreasi

:local send [:parse [/system script get tg_sendMessage source]]
:local param1 [:pick $params 0 [:find $params " "]]
:local param2 [:pick $params ([:find $params " "]+1) [:len $params]]

:put $param1
:put $param2
:put $chatid
:put $from

:local routeto [/ip firewall mangle get [find src-address="$param2" && disabled=no] new-routing-mark]

:local text "Router ID:* $[/system identity get name] * %0A\
Internet: _$routeto"
 
$send chat=$chatid text=$text mode="Markdown"
:return true

contohnya seperti berikut:

Mikrotik dengan Bot Telegram Interaktif 3 | PAIDJO.COM

5. Script tg_cmd_ping

Silahkan download ==> disini

6. Script tg_getUpdates

Silahkan download ==> disini

7. Script tg_getkey

Silahkan download ==> disini

8. Script tg_sendMessage

Silahkan download ==> disini

9. Membuat Schedule pada Mikrotik

Terakhir adalah membuat schedule pada mikrotik, lakukan pengecekan setiap 10 detik sekali. Perhatikan Video berikut ini untuk membuat schedulenya

Bila ada pertanyaan silahkan comment, dengan senang hati menjawab. Kalau ada salah atau mungkin salah mengetik silahkan dikoreksi juga di comment

Terinspirasi dari web labkom dan script pada github terima kasih untuk sharing ilmunya

Leave a Comment